Card unreadable


#1

Hello,
Today I received my card so was very keen to try it out. Unfortunately, when trying to pay in two different shops, both pay terminals said “Card Unreadable”. I was using the chip, not the magnetic stripe, as it is no longer used in The Netherlands.

Faulty card?

Bart


#2

Hey @b4rtw :slight_smile:

Have you tried using it at an ATM?


#3

Hello Juliopp.

No, I haven’t yet. But that wouldn’t help the problem I have with the pay terminals in the stores, right? My normal bank account card worked just fine.

Cheers, Bart


#4

Hey @b4rtw :slight_smile:

I’m not certain, but it is recommend giving it a try. Back then, I recall :r: recommended using the card at an ATM doing a small withdrawal. Who knows. It’ll be free anyway :wink:


#5

Ok, will give it a try.

Might get back to you though :slight_smile:

But thank you for your help so far @Juliopp


#6

I had the same problem today. I could pay wireless at the office for my coffee but couldn’t pay for my groceries at Albert Heijn tonight. Apparently not all devices in the market accept Mastercard/VISA?


#7

@arjan Thanks for the reply
Has the chip on your card ever worked?


#8

Was it Chip and PIN transaction that faied or contactless? Have you tried to check if contactless is enabled in the app? Cards > Security > Contactless Payments


#9

@Platin Chip and pin wasn’t working. When inserting the card in the card reader, I got the message ‘Unreadable card’. Haven’t been able to try contactless just yet.


#10

How about security options in the app? Are they enabled?


#11

@Platin App says the card is still on its way…? So can’t change security settings just yet?


#12

I think Julliop might be right. I had the same situation when I received my card. Security options became active when I took out cash for the first time, for some strange reason. This ATM withdrawal was the first transaction of any kind with revolut card, and soon after security options were activated. Give it a try tomorrow at ATM and then use chip and pin and you might be closer to finding the cause of your problem with the card. Good luck!


#13

Okay, this means then that the card isn’t activated yet. Activation happens with your first chip + PIN transaction. In theory, this should work with POS terminals in shops, and of course with ATMs.

It’s still possible that the chip is damaged, since you tried chip + PIN at a POS terminal already. You should find that out soon when using it at an ATM.


#14

I have the same problem on ATMs. Chip unreadable