Can't upload documents. Last chance before I give up.


#1

I need to upload documents to remove the limit.

  • Spoke to a “live agent”, he replied he needs to escalate to a relevant team… been waiting for 30 minutes!

  • Got an e-mail yesterday with a “set up your account now” button to upload the missing document. Problem is it takes me to a “you don’t have access page”.

  • On the “no access” page, there is an e-mail address to contact the developers. I sent an e-mail, got an automatic reply saying this address does not exist.

  • On the app, if I click activate your Revolut card, it takes me to the Verification & Limits page. There is a pink message: “Additional documents required”, but there is no way I can upload anything.

  • On the app, in the Profile section, the Verifications & Limits tab mentions “processing”. And it has been a looong time! Problem is I never submitted anything.

Thanks in advance for your help.


#2

…3h later, still waiting on the chat…
There is no way I can close this chat to reopen a new one! Even if I close the app… The guy or the bot (Radoslaw) never transferred me and never closed the chat.


#3

is ur problem solved? i am experiencing the same problem. wait an hour and no one replied


#4

Solved, someone else took over after 4 hours.


#5

you guys are so impatient…