Can't top up


#1

Hi,

I’ve downloaded revolut app today. My identity has been verified. So I wanted to order revolut credit card. The app said that I have to top up my account. So I filled all information about my credit card, chose currency of 10 Eur and hit next. Now it says “Please wait” and it keeps loading for a half an hour. I guess it’s not normal. And also it says “Please do not use the back or refresh button during the payment process. Please wait until the result has been processed…”. So is it ok to wait that long? What should I do?

Thanks


#2

Are you using a stable connection? Is the top up listed as pending on the account?


#3

It is the same with me. It’s pending and pending… What to do in this case?


#4

Problem solved.
It’s really strange that money got transferred, but this icon still kept loading. I just pressed X button, cause I lost my patience, and then checked my account, there were 10 Eur.


#5

I’m having the same issue. Any news on that ?


#6

Hi,

Even if it said do not turn it off till it’s pending, I did exit it and my
account was topped up. So it happens to me every time and I always do the
same


#7

Hi!

Yeap, I did that, tried a few times with different amounts but no luck. Card is VISA.