Can't Top Up and Card Declined


#1

Hello,

I tried to top up my Revolut Card 4 times today and I keep getting an error.
I’m using the same card I’ve always used and never had a problem before. Usually it requests the 3D Secure code, but these times it didn’t even reach that step, it just declines the topup.

Another thing that it is strange, is that I tried using my Revolut Card this morning on an establishment (where I’ve used my Revolut Card before more than once) and the card was not accepted either. Eventually I had to use another card, since the revolut was not beeing accepted for payment.

So at this point I have my card/account unusable since I can’t top it up and I can’t do payments.

The last time I used the card successfully was on the 24th of August (last week), and only noticed the issue this morning, so not exactly sure when the problem started.

Kind regards,
MissG


Issues with MasterCard Securecode Top Up
#2

Hello @MissG :slight_smile:

There’s a similar issue ongoing, check it here
Issues with MasterCard Securecode Top Up


#3

Thanks for the info @Juliopp.
I’ve seen that topic but since it only refers to top up I’m not sure its the same thing.

Cause in my case, the card was also refused :frowning:

But I’ll keep an eye on that topic as well.
Thanks :slight_smile:


#4

Hello again @MissG :smile:

Do you get any notification or log on your phone about the refusal?


#5

Hey,

the refused topups yes, they show up on my history movement as declined.

But for the card no, nothing shows up.
When I tried using it, the machine beeped and requested to use the magnetic stripe, I was using the chip, and after trying with the magnetric stipe the machine beeped again and asked for the chip :smirk:

The lady on the counter tried 3 times, until I gave up and used another card.
I checked the security of my card thinking that with the update something migth have changed, but everything is enabled, magnetric stripe, contactless, ATM, etc…
The card is also Enabled.

So not much more to look for…


#6

Hello @MissG :slight_smile:

Are the switch actually turned on?
Keep in mind switching the option ON means disabling the payment method, and not enabling :wink:

Also, have you tried withdrawing money from an ATM? What was the outcome? :slight_smile:


#7

Hello,
Indeed, the options are all OFF, so enabled.

I didn’t try ATM withdrawal yet. I was gonna try tomorrow, but I’m afraid that the ATM machine keeps my card if something goes wrong.


#8

Hello once again :slight_smile:

I would try with the ATM. However, get in touch with the :r: in-app support chat to see the reason of the refusal.
This could be a limitation for security reasons linked to the failed Top-ups :thinking:

Also, I assume you have enough balance in one single currency to cover the transaction, right? :slight_smile: