Can't register on the app

Hi I cannot register on the app. When I type my mobile number in and select a passcode it comes up with a message saying something has gone wrong please try again later

1 Like

They have never answered my question lol

Carl Jones ACE, FRC movement specialist, AYFit, WCO level 1, Adult and Pediatric First Aid/CPR/AED

Oppose Gravity

Cell: 0984104462

IG: @opposegravity

same problem here…

same problem here…

Same problem - deleted my account t as advised , because I moved countries , now I can’t open a new one , or log into the old one

I have the same problem, I put in my code in and then it kicks me out of the app can’t open it anymore and can’t to it neither. What should I do I am overseas and I can’t get on the app

Can you help me? I have same problem…

I can’t register. I have tried many times for the past month. Please help.

Hi, error message when I try to login with my iPhone. I have created my account with my iPad. Can u help me please ?

Hello, I have switched phones (new iPhone). When I try to register on the new iPhone, the system says it will send a mail but I never receives it. I tried various times but to no avail. I obviously checked my spam messages, but no luck either. And the address seems to be the right one as the second time I tries, the system shows part of my email address with * in the middle, and it corresponds to my address.

Help appreciated !

SAME PROBLEM, PLEASE HELP AndreasK!
thank you!!!

I HAVE THE SAME PROBLEM AAAAALL OVER AGAIN: Hi there, I downloaded the app and when I put in my number there is no problem until i try create a code and the a message pops up saying “We’re sorry something has gone wrong. Please try again.” I’ve uninstalled the app and tried again a few times and the same thing keeps happening. Is there anything that can be done?
Thanks
HELP, PLEASE!
I HAVE MY ACCOUNT https://community.revolut.com/u/igiigi
HEEEELP, THNXXX!!!

Hi there,
I have been trying to make a Revolut account for the past few days. I managed to get a code and download the iphone app, I enter my phone number and pass…and as I wait for a confirmation code nothing happens! I tried this a few times and every time its the same - no sms with a code and the time runs out!
I reached out to my mobile network in Bulgaria and they told me that the problem is not with them. Is it something with Revolut? Can somebody help out with this?
Thanks in advance!

I’m getting the same. I was about to confirm a payment and the app crashed. I reinstalled and it’s still the same. Can anyone help me

I am a Metal member and I can’t login to the app. It says that it recognizes my account, so I click login and it goes back to putting in my cell number.

Hello here! Got exactly same problem. After tipping PIN Revolut says “something has gone wrong”. Can anyone help me?

Same here. I have deleted and reinstalled the app 3-4 times and i always get the same message

1 Like

I already have 18 years and I can’t confirm my account

Hello everyone ! I’m facing the same problem on PIN code step while registering.
Can you help me @AndreasK ?

Thanks for the support !

Hello, looks like AndreasK can help but no contact whatsoever. How can I get in touch with someone to help on my problem?