Can't register on the app

@AndreasK

Hi Same issue for me

Can you please help

Thks

Hi @AndreasK I have the same problem and getting “We are sorry, something has gone wrong” error. Can you please help me?

Hi @AndreasK I have uninstall and reinstall the app and I cannot register account
and i get the error “We are sorry, something has gone wrong”.

Can you please help me?

Hi

Same here, please DM

thanks

Hi Andrea

I have the same issue,

Can you please help me

Thanks

Hi there,
I downloaded the app, typed my phone number, but when I finish entering my new pin code, I have the message “This device as already being registered”, so how do you want to get new customers like that???
Thanks

@AndreasK I can’t access my account. I can’t send you DM (dunno why).
I’ve logged out, and can’t login back.
I’ve reinstalled app. I am using iOS 12.

Hi! Ive been trying to register for a couple of months now and I’m also getting the error message. Please can you DM me to sort! Thanks! :slight_smile:

I have exactly the same problem. I can not take the pictures of my identity card. The application hangs down every time.
I have installed the last 5.17 version and still the same problem.

Same problem here. I cannot access anymore :frowning:

Hi!

My card is blocked and my account too.
My documents not verificated ans i can’t receive money from a another bank beyond 100$
I go to us in few days

Can you advise me on ID verification via the app? I have tried to contact via Facebook and the community forum but no response. I want to start using my account, the app won’t scan ID but will do everything else. how else can I verify my ID?

I’m also having the same issue. I can’t contact support on the app!

I’ve asked to change my phone number and instead they’ve said they’re doing the job and they went afk.

I can’t even get to the dashboard. I’m pretty much stuck!

Someone from Staff please help?

Hello, world…?

I’m about to sign up myself, but it’s not going that well and if I Google the error message I get, then I can clearly see that I’m far from alone, but none of the tips on how to try solve it personally seems to work.

Every step does work, excluding the very last one of the 1…8 steps:

  1. On the site (revolut.com) I start by selecting Swedish country code and my phone number with the correct formatting.
  2. I receive a URL that takes me to AppStore, and specifically to the Revolut app.
  3. Install the app.
  4. I start the application, and the first view I get is the one where I have to enter my phone number once again (and country code), so that I could verify ownership of the phone number.
  5. Configure a 4-digit pin
  6. Enter a 6-digit code (that is sent to me by SMS). Never any problems up to this point!
  7. Now comes the part where I get a centred black title at the top of the viewport “What are your personal details?”, followed by three input/text fields in a row. I should first enter “Legal first name”, then “Legal last name” and lastly “Date of birth”. At the bottom of viewport is a pink almost full width button, but having the state of “disabled” until I have fully entered my personal details.
  8. I follow those instructions, and I get an alert with an error message like: “We’re sorry, something has gone wrong. Please try later”.

Trying to solve this myself, what I’ve tried:

  • Re-install the iOS application (3-4 times).
  • I’ve tried pressing forgot my PIN, and then setting everything up one more time (1-2 times)
  • Restarting the app, etc…
  • I have also tested entering my name in every possible form I could think of while also looking up myself in our “national personal register” (in Sweden), in case Revolut is comparing my entered information with that register as well… But it never works, I’ve never ever had the luck of getting past this error message (step 8 in the previous numbered list).

How do I get this app up and running, I really wanna try Revolut! :smiley:

2 Likes

Welcome to the :r: community!

How often have you tried that? I don’t recall my process exactly, but it was rather smooth, at home, with good wifi.

If you are trying since today, it could well be there is an actual problem in their servers and that’s why you cannot sign up. Also, that you are 18 or older (or of legal age in Sweden if different)

However, I don’t recall that pink button (anyway, it could have changed since).

Make sure you enter your data as in your passport or national ID that will be requested after that for validation (I think mine was via a picture I sent them).

Let us know if it does not work in a couple of days, not that we can do a lot more, but good to know if it worked!

For the last two weeks everyone I go online to register in the app it says “we’re sorry try again later” I’ve deleted and reinstalled the app multiple tones and nothing. Anything at all to help please. (Irish)