Can't log into phone app

Hi
I have no issues logging into my account from a web browser on my computer but have been unsuccessful using the phone app. Currently, it asks for email then password, I get an email with a Confirm link/button but when I click this it just goes to the password screen on the app. I can’t get passed this, it’s just going round in circles.
I have cleared my app cache and tried but still the same

1 Like

Hello @dio :wave: ,

Welcome to our Community. Sorry to hear that you’re having difficulty logging into the app.

Have you tried the basic troubleshooting steps yet?

  1. Make sure your Revolut app is updated to the latest version available
  2. Clear the device’s cache:

iPhone: ‘Settings’ → ‌’General’ → iPhone storage → search for the Revolut app → select ‘Offload app/clear cache’

Android: ‘Settings’ → ‘Apps’ → search for the Revolut app → click on the app → tap ‘Storage’ → clear cache

  1. Close the app (close it completely from the app switcher)
  2. Turn your device on and off
  3. Try with both Wi-Fi and mobile data — ensuring that network connections are strong and stable
  4. If none of this helps, use an alternative device (if possible)

Try following these steps and attempt to login to the app one more time. If you’re still having trouble, don’t hesitate to get in touch with us so we can assist you further.

SG | Community Team

1 Like

Thanks. I did a complete clean down and re-entered all details and it works now

2 Likes

Great to hear that your issue has been resolved @dio. Keep exploring our Community. :slightly_smiling_face:

Was this helpful? Let us know.

  • Yes
  • No
0 voters

SG | Community Team