Can't get past the Continue button to send a SEPA transfer back to myself


#1

I’m trying to transfer my outstanding balance out of Revolut.

I’ve added myself as a beneficiary with the same bank account I used for top-ups (it’d be a SEPA transfer) but when I type in the amount and reference, the Continue button remains unavailable. No error message of any kind is displayed.

The app is updated to the latest version. I tried editing the beneficiary details multiple times but it does not solve the problem. Also tried force-closing the app and even restarting the device.

Has anyone experience the same and was able to find a solution? Any ideas what it could be?


#2

yea i have the same problem. If u know how to fix it, please tell me.


#3

In this case I was eventually told, after wasting several hours trying to contact support for one last time, that it didn’t work because the amount has to be at least €2.

As this restriction isn’t published anywhere, I made an ATM withdrawal first for as much as I could, so I had to top up once again before I was able to transfer the remaining balance out.

Perhaps this is also your situation?

Got the email notification for your reply. Coming back here makes me realize I’m so glad I no longer have to deal with all of Revolut’s shenanigans. Seems that things are even worse now than when I stopped using them.

:r:
:wastebasket:

:ok_hand: