Can't add new card


#1

Hello,
Just tried to add my new card today but after the “Cardholder Address” step when clicking the checkmark button to continue, it becomes faded and stays there forever.
Have tried with a second card too, same thing, reinstalled the app a couple times, even tried another smartphone but nothing changes.
Seems like a bug in the latest version of the Revolut Android app.
I have contacted live support but after 2-3 hours, the only suggestions were to uninstall the app, try again after some time etc…
Anyone else having this issue?
Any possible solutions?
Thank you in advance.


#2

Hello @Spgrvl,

Are you using a Greek Card?

Best,

Andreas K.


#3

Hello, and thank you for the reply.
I’m not using a Greek card, I’m using a card Issued in Italy.


#4

What’s the type of the card?


#5

Just sent you a PM in order to communicate more instant.


#6

I am having same problem trying to upload my card UK, but stuck on verification for 15 mins now and I can’t get out of it. Tried disconnecting wifi for a few minutes 5 mins ago but click on app and its still going round in circles. So frustrating. Any advice will help because I can’t even get onto in support app on phone now.


#7

Hi @Claire,

As I can see you have managed to top up, if you need any help drop us a line.


#8

Hi,

I am having the same issue, where i can’t confirm address, da because tick is greyed out. I have Mastercard issued in Slovenia.

Please fix the issue so we will be able to topup via CC.

BR, borut


#9

Hi there, looks like the issue is back.

I’m trying to add my MasterCard issued in Portugal, but after had filled out the card informations and billing address, i’m redirected to a “please wait” page that never finish waiting.

Thanks for helping