Cannot make card details visible in app version 10.x

Symptom:
Since I installed the 10.x version of the app I no longer can make any card details visible.

These are the steps I did:

  1. Select a card (working)
  2. Select “Show details” (working)
  3. Authorize to continue with pin (working most of the time, not always)
  4. Receive an SMS with a 6-digit Code (working)
  5. App shows the field to enter 6-digit-code for a fraction of a second and then goes gray, showing the rotating circle, indicating it’s waiting/processing something. It’s not possible to enter anything.

What I already tried:

  • Uninstalled the app, reinstalled it.
  • Cleared all data, uninstalled the app re-installed it again.

It did not help. I’m stuck and cannot make the card details visible.
The rest of the app seem to be fully functional, I can see my account data, transactions etc.

My currently installed app version is: 10.21.1 Mar 23 2024

Are there any further suggestions or ideas how to solve this issue?
Unfortunately with this situation I can not really use my cards anymore.

1 Like

iOS fills out the code for you in the background. This is how it is supposed to work unless you’ve deactivated that in iOS. From the overall description of problems, it sounds like connection problems. I would focus on that for troubleshooting. Switch between WiFi and cellular. Delete the app. Restart iPhone. Reinstall app. Don’t skip restarting the phone in between.

1 Like

I forgot to mention that I’m on Android, not iOS.
However, that gives an indication what may be wrong here.
I use a separate (Feature-)Phone for my Phone-Number.
My Smartphone does not have a SIM. It worked for years to manually enter the TAN.
Is it required required with App version 10.x to have the SIM in the same Phone as the App?

1 Like

Not necessarily, no. The app runs on tablets w/o cellular connection as well. I would try to switch off the cellular network on the phone, clear cache etc. and try again.

2 Likes

I uninstalled it, cleard all data, rebooted the phone and reinstalled it.
The registration (with selfie) in the app works but the credit card details still have same symptom.

As you mentioned that it works on tables as well I installed it on my tablet. There everything is working including the card details.

Thank you for the direction. That now works for me and I have some time to figure out what is blocking on my phone.

Hi,

I’ve just registered on Revolut, installed the app (ver 10.22.3 on Android).

I have the same exact symptoms when try to access my card details.

I also can’t send money transfers. I could add a payee (fingerprint or passcode required and working fine), then at the very end I have to approve the transaction and it hangs at this step the same way as when accessing card details. A Fingerprint and passcode doesn’t work. Then the app send me a SMS message which is automatically picked up by the app, and the six digit fields to enter the code grey out and there is a spinning wheel forever. I have to force to close the as nothing is happening when I wait.

Tried to speak to someone on the online chat today. Spent 50 minutes, been connected to two different person and another team supposes to get back to me within 2 working days.

So seems like a wider problem, not just your phone.

I haven’t investigated further so it remains unresoved on my phone. But it’s working on my tablet now which is good enough for me.

I want to add one more data point:

The phone which I have trouble with is on Android 11. Maybe someone from the support team can comment wether that’s too old?

1 Like

@greg_m Hello, Welcome to the community team. :sunflower:

  1. Can you please clear your cache for the Revolut app, and try again? Here, you can see how to clear device cache:

Go to Settings - Apps - Search for the Revolut app - Then click on the app - Click on Storage - Click on “clear cache”.

  1. Could you please try close the app completely from the app switcher, reboot your device (turn it off and then on), and try again?

If the issue still persists I advise you to wait as our team will definitely get back to you and help you resolve this. :pray:

Veda | Community team

Hi Veda,

Thank for getting back to me.

Tried that. No luck.

I tried it ong time ago, as forcing the app in the app switcher is the only way to go back to Android when the app stuck at the approval with fingerprint / passcode. That doesn’t help either.

I’m using Android 10 on a Sony phone if that helps.

@greg_m Hello :wave:

Please let me know if everything alright now, or are you still having trouble logging in? :eyes:

Veda | Community team

Hi Veda,
It’s not logging in. It’s an issue with approving certain tasks. But yes, still having the problem. Sorry to say that, but nobody from the support team contacted me within 2 working days as they promised (day 4 today) :frowning:
The app got an update a couple of days ago, but that didn’t help for the problem I’m having.

I tried with the most recent app version.
The issue remains unchanged also on my side: phone does not work, tablet works.