Cannot input a 9 digit US bank account number

Trying to send money to a business in the US with a 9 digit account number. However, the app will only let me input 8 digits.

Previous recipients have 9 digits no problem, but if I try and amend theirs as a workaround, it again only allows me to input 8 digits.

Anyone come across this?

Hey @levistubbstears :slight_smile:

Are you using the last version of the app? Have you tried reinstalling maybe?

I have just checked mine and I don’t have any restriction on the number of characters (12+) on either account number or routing number when adding an US beneficiary :confused:

I am having a similar problem: can’t enter 10 digits, only 8.

My payee has given me (edited for privacy) the information below but I’m stumped as to how to set them up as a payee in Revolut.

BANK NAME, Address Line 1, City, State, Zip
ABA: 123 456 789
Account: 1234567890

Tried deleting and reinstalling the app but no difference. Really weird. Especially when I try and edit a previous recipient who had 9 digits and it only then allows 8.

I’m still stumped.

Hey @rmaini :slight_smile:

As far as I know (I’m not very informed on the US banking system), the ABA is the routing number:

You can disregard the SWIFT code, you’ll only need the routing number and the account number :wink:

Hey @Juliopp

Ah yes, that makes sense and fits :slight_smile:

@levistubbstears and I are still stick with this 8 digit limit though. Nobody else have this problem? The first 4 digits of the account number are zeros so I’m tempted to just ignore the first two, but my experience with the US banking system tells me not to risk it!

I don’t recommend that. The account number I’m sending to just has a single 0 in the middle so that isn’t an option.

This is my experience:

I wouldn’t risk it either :stuck_out_tongue_winking_eye:
Maybe @AndreasK or @JessicaZ know what’s happening, but they might not be back until Monday (?). Have you tried asking through the in-app support chat? :wink:

@Juliopp Yep, will ask them when they open up tomorrow.

I wonder if its because I’m sending ‘To a business’ and you chose ‘To another person’ :thinking:

They’re open 24/7, so you can ask now and read the reply tomorrow :stuck_out_tongue_winking_eye:

Unfortunately, due to the large growth, reply times can be pretty long sometimes (should be around 4 hours now, you’ll be informed about it when you type live agent) :wink:

Thought you might have found the culprit, but no, same happens, works fine for me :frowning:

How do we contact them 24/7? On the chat feature it’s clearly automated and not set up to deal with a problem like this.

Any suggestions for best way to get hold of someone rather than waiting till Monday?

Two thougts: If you are phrasing a more complex question in the chat, Rita, the bot, will tell you that she’s not capable of helping you and will forward it to a live agent. This is the quickest way.

Or you simply type live agent.

Got through to them. It’s a known issue and will be fixed in the next update. When is that I asked? They don’t know!

Got to say it’s a pathetic response. The US has to be one of the largest markets in the world and we are unable to pay in.

I’m closing my account and going to TransferWise. They seem much better overall.

Hey @levistubbstears :slight_smile:

Can’t they manually submit a transfer meanwhile?

Google Play and iTunes ratings suggest otherwise. However, if you find other alternatives more fitting to your needs, good :smile:

Hi there. Our team is already aware and working on a fix!:muscle:

But what do you suggest for us customers who need to make payments to a US account? Can’t wait around for you to release an update.

Can you make the payment manually for me?

Can you make a manual payment for me in the meantime as I cannot wait for you to release an update?

Sent from Yahoo Mail for iPhone

I have the same problem. Asked Revolut help
and was told it was an issue for some accounts. It will be fixed in the next update.

Same problem, cannot do 9 digits. I was told it’s only a problem for iOS

Either way it’s incredibly poor and even worse that they released an update yesterday that didn’t solve the issue.

How can they expect customers to take Revolut seriously?

Incidentally, I’ve now moved my business to TransferWise.