Cannot collect money - form fields reset after completing


#1

I’ve had this problem for a week now and reported it through in-app support. They say that the tech team is working on it but it seems strange that it hasn’t been fixed in that time, so I’m wondering if it’s just me, or just Canadian $ that cause the issue.

I’m trying to send C$ to my daughter in Canada who doesn’t have Revolut. So I choose ‘Send money’ and create a link just fine. I share the link with her and she clicks to collect her money. However, after she enters her address details on page 2, when she clicks ‘continue’ the form resets (all but the first letter of her first name and the country, as shown in the screenshot) and all the fields get a red error message saying ‘Required field’.

Re-entering her details has the same result. She’s tried on her phone and in different browsers (including IE and Chrome) on different devices. I’ve tried, using her details on my laptop using Chrome and my phone using Chrome mobile. Always with the same result.

The amount is only C$400, so it’s not a massive transfer. She successfully collected a C$100 transfer using this method just over a week ago. But now it doesn’t work. After 24 hours of trying, the link expires and I create a new one. But it’s always the same result. We’re on our 5th link now!

In-app support couldn’t provide an update - they just say the tech team are working on it but I’m not even sure that they recognise the problem.

Has anyone seen this? Can anyone help?


#2

Have you tried a regular transfer instead of the link while they figure out what is wrong with the form?


#3

Hi there!

We’re really sorry for any inconvenience caused. The team is working on a fix and it should be fixed soon. In the meantime, you can proceed with a regular transfer.

Tap the pink button on the main navigation screen in the app. Select ‘To bank account’ and tap ‘Add a new beneficiary’. Add your bank details, then you can simply enter the amount, currency and hit send.


#4

Could you please let us know what browser are you using to open this?


#5

Hi,

Sorry for the delay, I didn’t get notifications of the replies so I only found out they were here when I checked in just now.

A bank transfer is next on my list to try if it’s not fixed after the weekend. But I’d rather avoid it as there’s more risk of the account details bring entered wrongly with a double transcription (my daughter to me then me to the app). By getting her to collect then it’s just her entering her details that she’s familiar with, once. Much less prone to errors creeping in.

We’ve tried multiple browsers between us. Mostly Chrome though. Either on Android phones or Windows 10 laptops. Also latest versions of IE and Edge on Windows 10.

Still not working with a newly created link 10 minutes ago.

Thanks for your help so far and it’s good to know that someone is working on it.