Bug: 6.24 account statements on Android defaults to GBP

For tax reasons I tried to generate PDF statements for December last year.
Every time I tap “get statement” it switches to GBP.
I have tried this on various currencies and it always defaults to GBP.

3 Likes

Even worse! Mine says 0 for every item. :joy:
This needs a fix asap as I think every Italian will post this. I think they need them badly, don’t they?

edit: Excel opens a new email with the .csv attached. Is that normal? Also all 0 for me.

another edit: I reported it via in-app chat.

It has always been the default behaviour on my smartphone. Also, I have been annoyed by it ever since because it doesn’t offer a direct download option.

…and maybe you do not want to share it with Gmail or sent it through the webs! :joy:

if you leave the email screen by using the return button, the email is saved as a draft. Then you can download it from the draft.
Though, at that point it might already be synchronised with the server.

1 Like

You got it. :slight_smile:
Also:

I encountered even another bug: When I switch the accounts it doesn’t always change to the respective transactions.

Edit: seems to only have been a temporary problem

Not on my device atm. :man_shrugging:t3:
However, I had it before and sometimes the point that should Mark positions on the graph freaks out. :joy:

I also found this and reported via in-app chat.

The new (beta) version I received yesterday fixed this. The account statements are now generated for the selected currency (in my case EUR and SGP. I don’t even have/need a GBP account).

can u help me to? like at the ID verification i always get this


and i cantdo anything. i ve been struggling for about two weeks help

Any progress on this? I am a UK user, returned from a trip to the USA. Statements either PDF or excel requested on the US account bring up only the GBP account ( transfers). I use a Moto 5g running Android 8.1.0.

Hello.

Lately, the Revolut apps started to crash as soon as I entered the app. The only thing that appeared was the logo, and after a few seconds it crashed.

So I uninstalled the app, and re-downloaded it again. It was asking for my phone number, so I put that in. Next it was asking for my PIN, which I also put in. After that it was asking for the confirmation code that I got via SMS. So I put that in as well, then a circle has appeared, as if it’s loading, but then it disappeared and nothing happened. I was left via the screen asking for digit code, with the code I’ve already have put in. Nothing happened. If I tried to remove the code and ask for a new one, and enter that, now something else happened: an error message came up saying “We’re sorry, something has gone wrong. Please try later”. I’ve repeated this procedure various times with the same result.

I can’t seem to be able to access my Revolut account now. Please help me.

I am using an Android 7.1.2.

P.S.: Creating a new topic was very tricky on your site, you should probably do something about that. There is no “New Topic” button, I had to go in an existing topic to create a New Topic.

Thanks.

Hi,

Was there a fix or work around for this. It has happened me and I need my statements urgently.

Thanks Justin

No, we can’t help you here. You both will have to contact Revolut on Facebook or Twitter.

Bug is fixed with 6.25 update