Brexit ahead of time? SEPA transfer no longer possible?


#1

Hi everybody!

I tried to top up my Revolut account via SEPA Transfer. Three different German Banks have declined my Revolut IBAN, claiming that this very IBAN was outside the SEPA area (propsing to use an expensive SWIFT Transfer) . It did work ou before… Can anybody clarify what issue we are having here?

Thank you!


Transfer from Paypal still pending
#2

Hi there.

Thank you for contacting us.

Please request your bank to send the transfer to LIABLT2L.

If this does not work, please try again tomorrow using REVOGB21.

Best,

Andreas K.


#3

Hi Andreas and thank you for the swift answer. I mean… rapid answer, just to avoid misunderstandings. The Problem is: I don’t even get to enter the BIC, all banks already decline the IBAN. Seems they do not recognize the GB…REVO… IBAN as a valid IBAN for a SEPA transfer.

If you are telling me, I can use the IBAN/BIC again tomorrow I reckon this is a temporary problem that will be solved? In that case, I have no issue at all…

thank you,
buenasnoticias


#4

See this other thread:


#5

Problem seems to be solved. SEPA transfers out of German bank accounts are working again. Tried from 2 different banks, no problems any longer.


#6

Problem still here from Belgium (BNP Paribas) Tried 2 SEPA transfers one last week and one on Monday this week Euros to Euro Revolut account and nothing showing on my Revolut account. Will wait a couple more days then just go back to the real banking system, they might charge a lot but at least your money actually arrives.


#7

Support said it was fixed from Tuesday onwards. You missed it by one day. :wink: You can also double check the BIC that your online banking deprives from the IBAN. If it matches the BIC shown in the app, your bank’s database is up to date again with the right details.

(Failed transfers should bounce back automatically within a couple of days. That not only depends on Revolut but also on how your bank handles these failed transfers.)


Top-up does not arrive
#9

Hi same problem my transfter changed suddenly from REVOGB21 to REVOGB2L
CAN SOMEONE PLEAS ADVISE WHAT TO DO?
This is totally unprofessional