Auto-exchange does not allow for setting target / do not work.

Starting from 15 Dec 2020 I do not have access to auto-exchange.
The issue started with the update I did prior to that day…
Initially, when I set buy/sell and auto-exchange, all the buttons were greyed out.
Since I updated to version 7.29.3, I was able to “buy/sell now”. But auto-exchange still does not work. I currently have version 7.30.1

Funny fact, I have a Premium account. In other words, the company did not solve the issue with the basic functionality they provide for free, for a paying client.

Anyone else has the problem with auto-exchange as well?

I have exactly the same issue. I chatted many times (2) with the client services. Apparently they are working on solving the issue. I don’t understand it’s taking that much. First chat was on dec 16th.
It’s one of the best features of this bank. I’m really disappointed that it’s not solve yet

can’t set target rate for cryptocurrency

For me it does not work since couple of weeks. I am really annoyed. Mostly using this for cryptocurrency exchange. This is most desired functionality that does not work. Please correct it !

It’s almost a month since the issue appeared.
I am paying client. SO … I am considering issuing official reclamation.

BTW, How many people have that problem?

For Fiat currency, tap Favourites, scroll to the right to Orders, Tap New, choose Currency to buy, Tap Limit price at the bottom of the screen. There you can set the price for an auto-exchange.

For Cryptop, have you tried, Open Currency, Open Buy (Sell), tap on rate, Tap Auto-Exchange, Tap Set Target, enter rate, close it, enter amount.

These work for me - even if it is a ridiculously long way around it

That do not work for Commodities.
Silver, Gold …

It does on mine. Just the same. You have to use the same functions as Crypto. Perhaps you need to update the app? They have made some changes recently. (I’ve used this function several times in the last week.)

I have the newest version. Checking for updates availability every day since 15th Dec.
Reinstallation, cleaning the memory. System update… Done it all.

Have you faced any issue where you create an auto exchange, but it doesn’t show anywhere? Actually, I struggle to find the pending out-exchanges every time, every time
Anyway, I just tried again, created one, and I can’t find it, it is not listed in the orders pending.

Apparently (according to the help section), they’ve done this to make it more line a broker trading platform and market ordering system. But who wants that when they’re changing money quickly. I think they have to decide if they want to be an easy conversion institution or a broker!

Well, mine has just updated again. Think at least second time this week, as I use this function nearly every day. And they’ve changed it. And the new way is absolute rubbish - not to mention it took me ages to find.

Hit the star for Favourites on the main screen, scroll right at the top line to Orders. Here you can see ALL pending orders (even for crypto - which should get under wealth, but never mind).

Hit Add New at top right.

Then you have to decide if choose the currency you want to end up with (because you can no longer switch/toggle this with the “up-down” arrows, like before). The currency you want to buy will be on top, selling is on bottom.

Hit Set Up, to the right of Limit Order at the bottom. Then you have to enter the max price for the currency you are buying, and there’s no more chart to guide you on recent prices. [Insert angry, bewildered face] (There is also a way to set up a stop order for the minimum price, but now I can’t find it.)

I had to use the Help function to find this. It’s a terrible, awful way to do it!

A couple hints, your experience might slightly vary if you’re not on the latest beta, but then it might be something helpful for a future release.

The star icon is one option to access exchanges, but there’s another one.

Tap on any currency flag on your homescreen. Instead of exchange, you’re now seeing buy and sell buttons, tap one, it doesn’t relay matter. Or tap on the options button “…” and find buy/sell directly from the homescreen for every currency you’ve got there.

On the next screen, under the headline, it might read “Market order at 1 € = 0,8983 GBP”. tap on market order to change the type of order. Tap on the rate to see the graph. Tap on the upwards arrow between the two form fields for amounts, and it switches from buy to sell — this is effectively the same toggle action you mentioned.

All pending orders for currencies, commodities, stocks, crypto … are unified on one page, accessible via the Favourites star icon. This Favourites section is accessible via homepage and via wealth.

With the newest update, everything works again.

I cannot auto exchange crypto anymore. This was working fine up to a few days ago by there is no way of doing it. I’ve tried favourites-order-new order but it doesn’t have any crypto. Any ideas?

Mine does not work either?
This is on iPhone.
I go to sell, click auto, choose the amount of XTZ i wish to sell then press set target.
I then enter a value for 1x GBP amount ( I presume is the rate I want to sell at, for example 2.50). Then I click auto exchange button.
The values are removed nad nothing happens…
Am I doing something wrong!!??
If I push the back button and scroll down, there is nothing there.
(I presume that is where it would be).
Any alerts are still there.

Any ideas?


On mine worked only for 2 days and now it’s gone.

Hi, I agree with the comments above, I have a EUR account by default but when I go to crypto and try and buy or sell, it defaults to USD which is really annoying. If you did not change the currency beforehand then the ‘limit price buy/sell’ will still be in USD… it is a waste of time. I preferred the auto exchange shortcut which was very quick to setup. Ideally if the ‘orders’ recap could have a way of filtering for a given currency/metal or crypto, would be perfect.

Hi, greetings to all. I have already coupe of days the same issue as the other Revolut user in this thread. All auto-exchange orders do not work for me. Greyed out buttn to confirm it :frowning: . It is the same for stock, crypto. It is also the same for sell or buy orders. What I already tried:
-changed currency for these auto-orders, same issue
-checked my version, it is up to date
-uninstalled app, restarted phone, installed app again, same issue

Any ideas?

Thx a lot.