Apple Pay "Add a card that is accepted by this app"


#1

Hi.

I just tried to top-up with Apple Pay as I have done many times before. This time I get a dialog saying: “Add a card that is accepted by this app”. My card hasn’t changed (SwissBankers Mastercard) and Apple Pay works fine for everything else. Any suggestions?


#2

I just tried it now, topped up CHF with my swissbankers card via Apple Pay. Working as usual, no issue.


Apple Pay Top-Up with non EEA Cards
#3

Hmm. Still doesn’t work here. Yesterday I did a top up via may TransferWise Card. Before I had never added a card and only used Apple Pay. I wonder if this confuses it.


#4

Try to add your swissbankers card to Apple Pay and make it the main card for Apple Pay. Then you should be able to top up in Revolut via Apple Pay.


#5

Thank you.
It is and always has been added and primary. I use it all the time.


#6

Strange that its different for me


#7

Indeed. Very odd behavior.


#8

So I did a few more tests. Removed and re-added my SwissBankers Card to Apple Pay. Same result.
I also paid online and in a store with Apple Pay with no issues.
Topping up TransferWise with ApplePay worked as well.
All signs point to the Revolut App being at fault. Maybe the last upgrade introduced a bug?

My account is fully verified and I have topped up via Apple Pay with the same card. The only thing that changed between the last top up and today is that yesterday I added my TransferWise Card to the Revolut app (and verified it immediately). Maybe that confused it?


#9

Maybe Revolut’s database now has the card marked as a ‘commercial’ card? Or non EEA issued card. Hence the rejection? Were you able to top up using Apple Pay with no fee previously? Revolut now charges for non EEA issued cards.


#10

Mine is still working. But I have not added another card to applepay.


Apple Pay Top-Up with non EEA Cards
#11

Then I would think @Gekko 's card wouldn’t have worked either. Paid a fee once in November. Never since.


#12

P.S. Now that I think about it. I actually have more than one Apple Pay enabled card in my Wallet. So it is not a card issue. Even if I change the default card, same story.


#13

I am experiencing the same issue with my Barclays debit card. Same message pops up when I try topping up my GBP balance using Apple Pay. I only have 1 card in the wallet and it used to work just fine. Bug perhaps?


Apple Pay stopped working
Apple Pay Top-Up with non EEA Cards
#14

Glad I am not alone. Looks definitely like a bug.


#15

I noticed the same and alerted a chat advisor. I’m a Premium Customer.

The advisor said they would pass this onto ‘The Technical Team’. I’d imagine this would get priority, considering it means some of us can’t top-up


#16

Well this sucks (albeit my card isn’t issued in any of these, so my issue remains)…look what a Live Agent just told me…

“Can you please clarify where was it issued? As since new release we stopped accepting cards issued outside of the list as Apple Pay top up method. The list: AT, BE, BG, CY, CZ, DE, DK, EE, ES, FI, FR, GB, GR, HR, HU, IE, IS, IT, LI, LT, LU, LV, MT, NL, NO, PL, PT, RO, SE, SI, SK, IM, JE, GI, GG.”

Since when did this decision get made? Did I miss this.

FYI to all


#17

While I am not saying the Live Agent’s answer is false, it strikes me as very odd.

First of all, most of the listed countries don’t even have Apple Pay. See here: https://support.apple.com/en-us/HT207957

Second, I didn’t see any announcement in the App, Blog or Forum about this.

Third, for Switzerland in particular, they would be removing the only free top-up method.

Fourth, @Gekko claims he was able to top up fine with Apple Pay.

Any chance @AndreasK can corroborate?

Should this really be the case, then Revolut becomes pretty useless for me in Switzerland. Topping up CHF via Bank Transfer is way too expensive and if the only free top up method is the TransferWise Debit Card, why use Revolut at all. Once money is in my TransferWise BorderLess Account , I can spend it with their Debit Card taking advantage of excellent exchange rates and intelligent currency routing.


Apple Pay stopped working
#18

Hi there.

I’ve escalated this to our tech team :slight_smile:


#19

Thanks @AndreasK - confused why a Live Agent even gave me an ISO code list? Oh well, glad it’s technical and not a withdrawl of practical :slight_smile:


#20

Don’t shoot the messenger :wink: judging by @AndreasK’s response, looks like I was misinformed, anyway!