App login issues

I’m having the exact same issue. I’ve been stuck for +2 weeks and nobody will answer me. Can someone please help us out?

I just got a new phone and trying to login - it won’t allow me, says I need to sign up not sign in. The phone number on my apple wallet also changed showing an unfamiliar number even though my email is still connected. Can someone help me out figuring a way to log into my account through my email address??

Ask them on Twitter or Facebook, they will answer more quickly than here (they resolved my problem in 1 hour on Twitter)

I’m having same issues, put your phone in, put password in, email but no authenticate button.

Tenho esse problema quando acesso minha conta Revolut. Como devo fazer

alguém pode me ajudar,já enviei o e-mail.

Same here, what a joke!

I had to reset my account PIN number was not valid, they asked for a photo with ID to verify after the second attempt it was finally verified. I have been an hour checking my email as I need to click on a link I suppose, for the final verification process. I have uninstalled the app went through the process several time but no email received. Please help.

Hello, I have the same problem… Ive bought a new phone and tried to login from my old phone to my new one. However it won’t let me login and forces me to create a new account…

Hello , i have problem with my number i am not able to log in to my Revolut account.
is not recognize my passcode as well as verification code.
Can you help me to log in ?

When I open the app I get stuck with this screen.
And I have been waiting to talk to a live agent for 3 weeks! @anon33247966

Hello, I have a problem with logging into the application. I’ve typed right password, but the spinner/throbber is stucked. No error or any kind of message is displayed. I have the most recent update. What should I do?

I have the same login issue , app is up to date ver 7.10.2 android
I have restarted the phone .
can only get to the login screen then the “waiting loop” no further.
Tried with fingerprint and PIN ( same result )
Verified PIN is correct ( by entering the wrong one)

All support is via the app (which is not very useful if you can access it )

any suggestions from knowledgable source appreciated.

1 Like


I cannot make a new post but wonder if this will be picked up by someone anyway. Finally was at the top of the waiting list after many months of waiting, my pin was refused (has happened in the past) and entering my phone number to reset it only gave the message ‘This action is forbidden’.

Reinstalled the app and I’ve been placed at the very end of the line again as if I’ve just registered. Any ideas because I’m not waiting another 9 months when I’ve already done my time

I haven’t use my app for a while and now I am unable to log in. The system is not sending email therefore I am unable to verify my identity. Please help!

I can’t log into the app because the app doesn’t recognise that I am an existing customer. It tries to force me to be a new customer.

This happened after I had to reset my phone and reinstall the app.

maybe This helps you people , I figured it out myself( see previous post 04.AUG) , I pressed and held the widget ( its a short cut ) and it said app not installed ( even though it showed on my phone)
so I force stopped it ( settings ) installed and reinstalled the app(settings)

Entered my PIN and took a new selfie and Im back to normal operation

I am having the same problem.

Hello. I created an account with revolut in december while i was in turkey, but I did not use it because you receive the credit card at your residence. Now I am trying to log in, but I am having some problems since i dont remember my old data and I cannot create a new account since they already know my data. How can I solve it? Thank you in advance

Hello, i have the same problem. For about two weeks i can not login to the app. I put the password or the fingerprint and it keeps loading. I have updated the app today in the latest version.

1 Like

Hi, I can’t login on a new phone. Same number. The app has no way other than creating a new account.

Please help