App Issue

No still not. I was away for Christmas holidays so my phone number was not the same as country from where I tried signing up from; I thought that might be the reason but no; came back yesterday and retried: uninstalling the app, deleting data, reinstalling, resigning up and no, the problem is again at the same spot, the loop of creating and repeating password.

I’m surprised that no one official has given any reply or a possible solution to the issue as I saw them active on other problems and questions from clients. Is there maybe another way of signing up?

1 Like

Seen a few complaints on Reddit about people being caught in a register/login loop.

1 Like

Did you solve that case?

1 Like

Hi,
I’m not sure how to do a new post.

I can’t set up new personal vaults as it comes up with an error message saying something went wrong try again later, it’s been doing that for 2 weeks.

I upgraded to metal today so my interest rate should upgrade to 2.5% but I’m getting an error message for that aswell saying somethings gone wrong try again later. I’m using an iPhone XR with iOS 16 and have updated the app. I’m now not getting the 2.5% interest in my saving despite paying extra for metal.

1 Like

Hello, I have a problem with… my account, I think? I created my revolut account, but then accidentally deleted the Revolut app. When I downloaded the app again, I could’t log in to my account. I received a message with the authentification code, entered it and got an endless loading screen. When I tried to log in with “forgot your password?” button, the app told me that there is no account attached to this phone number/email. But registering doesn’t work, after entering the code I’m getting back to the main page. And other strange thing - my friend told me that I should have received a email confirmation letter but… nothing. I have only a letter with documents, but doesn’t it mean that I have an account? So I can’t login because I “don’t have an account”, can’t register because of unknown error and I haven’t received some important letters. pls help

1 Like

Hi everyone :wave:

Sorry that some of you are facing issues with logging in :frowning_face:
But worry not, we have created a Topic with some of the most frequent issues, and we have covered yours. :toolbox:

Hope this helps :smiling_face:

Veda | Community Team

3 Likes

Hey in wanna ask you guys im have problém to login to mě account im login with my phone number And PIN And app say Wrong phone number or PIN but if im login with email same what problém Its is

2 Likes

Hi @Majky1992, and welcome to our Community :wave:

You can see on the post just above yours from @Veda.Ramesh a link to a Topic to help you get access to your account :wink:

Let us know if you find any issues!

2 Likes

But how im fix this problém with login?

So in never fix bug with login in si bad

A post was merged into an existing topic: Login Passcode

I want my verification processing to be completed today please

1 Like

Hi @Harri10, and welcome to our Community :wave:

If you’re waiting for the verification result, please note that it can take anywhere between 10 minutes and 24 hours or more for you to hear back from us. If your verification has failed, please try again and double-check that your images are clear and all document photos are readable without any blur or glare.

You can find more information about it here :iphone:

Hope this helps!

2 Likes

Also new, registered to find help :grinning: Want to create an account but… after trying a lot of things I found that on my phone the app only shows sign up and login button in airplane mode. On WiFi or 5G only the introduction slide show is shown, no buttons. Have no idea on how to fix this. Any suggestions?

1 Like

Hi @parmarecto :wave: and welcome to our :r: Community!

Have you tried updating your phone software to the latest version, and check if your Revolut app is on the latest version as well?

Hope this helps :hugs:

1 Like

Apparently the app does not work with 5G. Switching to 4G did the trick. Hope that the next update will fix that :pray: Thanks for the quick response :+1:

2 Likes

Thank you so much :hugs: Happy that it got solved!

A post was merged into an existing topic: Can’t receive registration sms