App incompatible with your device


#1

I have just bought a Galaxy J3 and have tried to install Revolut App. I get the following error message:
This app is incompatible with your device.

This is a brand new phone and it’s out of date already? Do I seriously need to shell out £800 just to use this app?


#2

Hey @PocketAces :slight_smile:

You would be able to use :r: even in a Oukitel C4 Smartphone (which costs merely $60/£45) :wink:

Which Android version is your J3 running on?
At the moment :r: is available for iOS >8 and Android >4.3, with a minimum screen size of 3.5 inches.


#3

Strange. I have Samsung Galaxy J3 (2016) with Android 5.1.1. And app Revolut 4.8.1 works on it as a Swiss watch ;-).


#4

IMHO it is very weird. AFAIK the oldest firmware for J3 is 5.1.1 (Lollipop) with screen size about 5 inches…
Probably support contact is inevitable

BTW. I googled this:

I know that this is another device and app, but… error looks similar


#5

Thanks for the replies everyone. I have now got the app installed. Maybe my phone was just having a bad day.


#6

#7