App crashes when adding personal details


#1

I have just relaunched the app after a while away (as it’s only used for holidays) and after I enter my pin it asks me for my first name, last name and DOB. When I do this and then click update the app crashes. Tried restarting the app and restarting the phone but same results… any ideas.


Can't sign in
#2

Just asking, is it up-to-date?


#3

I have exactly the same problem. Tried to use the Android app a week or so ago for the first time in a few months and got asked for my name and DoB but the app crashed when I tried to enter them. I think it may be something to do with the format of the DoB because after selecting the date from the pop-up calendar it only displays the month and year on screen, not the day. I was definitely on the most up to date version of the app when this started happening. Last week there was an app update and I thought “Oh good, this will be a fix to the problem” but it has made no difference. I need to use the app and card for a holiday in a couple of weeks time so really need this to be resolved.


#4

Another question, was it a Samsung device by any chance? :slight_smile:


#5

Mine isn’t a Samsung. It’s a Nexus 5X.


#6

I have a similar problems with my Sony phone - any suggestions please?


#7

Just trying to find a temporary solution while thing gets fixed by :r:
Are your phones set to English as language? If not, does anything change if you switch it to English?
What’s the phone and the Android version?

Regarding this… Phew. Any screenshots?


#8

My phone is a Nexus 5X set to English and the Android version is 7.1.2. I’ve posted a screenshot below. Actually I just noticed that the DoB displays the year and day (rather than year and month as I said previously) but, either way, it’s clearly displayed wrongly. As soon as I click on the “Next” button the app crashes.


#9

I tried to go through the same steps and… It worked :confused:

I’m not saying this is the final answer to the problem, but those of you in a hurry might want to try to login from another phone, complete the steps and then use your phone again? Only until the problem is fixed :slight_smile:


#10

Unfortunately I don’t have another phone that I can install the Revolut app on. It’s interesting to note that in your screenshot the date seems to show correctly whereas in mine it is displaying incorrectly.


#11

That gives a chance that the problem is device-based and can be solved with another device as a workaround…
Maybe a friend’s or relative’s phone, as it will only be login+update and then you can use your own phone again I guess :smile:


#12

OK, the problem is now resolved. I contacted Revolut support via Facebook and they said I was somehow running an old version of the app (even though I always keep all my apps up to date). They asked me to uninstall and re-install the app and that fixed everything. I am now definitely running the latest version of the app and I am no longer asked to enter my name and DoB when I open the app.

Thanks so much for your efforts to help resolve this. Hopefully by posting the solution this may help a few other people.


#13

Hope it works for everyone and @george.chapman marks your answer as the solution :slight_smile:


#14

I had exactly the same problem, on an HTC M7. running Android 5.0.2 with HTC Sense.
LIke the original poster, I thought I had the most recent version as I downloaded all updates (most recently about a week ago)
I also had the incorrect date format shown when entering personal details.
It was resolved by the de-install re-install route.
Thank you.


#15

Same issue on a Nexus6p - uninstalling and reinstalling solved the problem, ironic given that the issue only began when I updated the app 2 days ago!