Am I the only with "Create payment link bug"?!?

Since my first use of Revolut app and ever trying a lot of app updates I got an error when I try to create a payment link… I can fill all fields and when I press the confirm key I got a “Sorry, something has gone wrong, please retry error”… (as in picture…).

I contacted online assistance and they told me to try to uninstall app, restart phone, reinstall and login again… with no success.
Then they told me perhaps I wasn’t “fully certified”… I reply it doesn’t result to me but I asked how to check it eventually… no reply. OK.

Then I tried A LOT of updates… no result.

This evening I tried to contact assistance on Twitter… very prompt in reply me (!!) BUT… same “uninstall, restart, reinstall, login” again… :roll_eyes:

What I don’t understand is… am I the only with this issue?!? :thinking:

More… Is it so hard to check (on logs?) what happens when I receive the error message? :thinking:

2 Likes

I’ve got the same problem, the thing is that happens with only one person and has everything correctly. I need help!!!

Have you tried to contact help? With what results? :thinking: