About the Bugs category 🐝🐛

Hi, there’s a typo when removing a custom category:

Not sure where to post this, as I am unable to create threads. Can a mod look into why I cannot create threads? Thanks!

Hi! I sent this issue about 2 months ago and still the same problem… They are putting new options, services, whatever… but since the update with this colours…horrible. Did you receive any solution?

Since i received my Revolut card, i cant do nothing with him, i tried to pay the restaurant bill, and was canceled (contract canceled) , then i went to a ATM, to do a first transaction with the card,the system ask me for my personal number with twelve characters… wich one? my phone number? after two tries of wrong code, i gave up… i hope you could help me with my problem.

I reinstalled Revolut App and need to login once again. After inputting my phone number the screen with confirmation of my e-mail appears but there are no e-mails from Revolut received in all folders including spam and junk.
Please, help me with this issue. Customer complaint was sent 2 weeks ago and still there is no reply.

Hi There,
I had an issue with a payment yesterday.
I had 499€ in my Euro account and 65£ in my UK account.
I am in France and i tried to pay 500€ and i got : payment declined.
So i have transfered 499 € to the UK account and it worked

So i have 2 questions :

  • why does my card take the money from the UK account and not the € account while i am in France ?
  • i thought that the card would take the money from the € and complete with the UK without having to make transfers.
    Can you please provide me some details on how the payment works, i could not find those details :slight_smile:

Thanks a lot

I have a problem and I don’t know where to contact the technical support

@anon33247966 hi can you or anyone help me and my sister, i dont know how to send private messages on this. we have a house sale gone through, moneys left buyers account and gone into our revolut account we opened about 2 weeks ago for this very purpose. you guys asked for more info, we sent you all relevant documents proving sale of house, and now account seems locked only a “chat with us” option, with no one ever replying. please help, the buyer is threatening to back out of the deal, because money has left his account but we can’t access it or even get confirmation or anything from your company with updates that we will ever get it. please help. they threatening to pull out in like 11 hours.

Hi, after a while I was trying to log back in to my Revolut app (android).
After typing in my phone number it’s asking me to click verification link sent to my email address, problem is I don’t have an access to that email anymore.

How can I access my account?


I have a friend saved as “Nickname” on my Phone contacts.

after I added this friend on Revolut I saved him with “full name” in the Revolut App.

since then, Every Notification (from Whatsapp, Telegram or SMS) I get “Full Name” instead of “Nickname”

how can I change his name in the Revolut App? or why is it interfering with my phone contacts? he is still saved under “Nickname” in my contacts.

it’s annoying as hell because I use color-code emojis next to the nicknames of my friends to recognize them when I don’t have glasses on :frowning:

Well, it seems that I can’t create a new topic about this issue.

The option about ATM report (wrong location, incorrect details, etc.), it is not working. You can select any option, fill the details in the next screen, but neither the camera nor upload files buttons works -camera give you a black screen asking for permission to the app, it has, checked twice, it make selfies without any problem-.

Even without pic nor document, the next screen ask “again” for the issue, and the report, eventually it redirect you to a web-based screen without any confirmation.

It happens in two different phones with different app versions, both Android and with the full app permissions in both.

Can anyone help me with this? I can’t start a new topic yet. I would like to be able to print a statement for my vaults, but I can’t see how.

I’m on iOS. After recent updates, when downloading and printing out individual transaction, the footer overlaps the transaction section of the file and makes the PDF illegible. Please look into this problem for the next update, thanks.

Hi can please help to check why cannot use my mobile number to apply for an account via apps? Thanks thanks

Sorry mate, I think the only way it’s to export the whole statement for an account and specific currency in an excel format and filter this excel to show you only the vault “column”, and work from there to extract the data you need.

As far as I can see, you can’t export a “vault only” statement from any place.

Hello, I tried to open the app yesterday in order to activate my card (after months without using it): it keeps loading forever but never gets to open. I figured out there was an update so I updated the app… same issue. The rotating circle keeps rotating forever…
on Android - Samsung Galaxy S7 up to date 2020.08.01
Someone with the same issue ?
Someone from Revolut can help, please ?

deleted app, removed files, reinstalled app => ok

Hi there! I was using my Revolut account and a card for a few years and suddenly I’m logged out from my app and when I’m trying to log back in the message “couldn’t restore your account” appears. What should I do in this situation? Could anyone help me please?

Hello everytime i press the app on my phone dont open and crash i need to open my account

Issue with spare change donations

I was trying to make an online purchase with a disposable card. And there was something wrong in their system, so it kept getting declined. But the balance was decreasing and I couldn’t figure out why, as no transaction was appearing. I checked the statement and for some reason it had been subtracting 10$ and sending it off as a donation.

So as I had tried a few times in my end to get the original transaction through, it ended up sending 70$ to medicine sans frontières ! Ans looking back through the last several months there’s been a few occasions where this happened, with me thinking it had gone into a vault. Had to deactivate the donations. But this is a serious bug!