3-D Secure Prompt not showing


#1

I cannot use my credit card with 3-D secure to top up my Revolut account anymore. If I try to issue a payment or add a new card (which results in a payment of 1.00 EUR):

  • A box saying “Your card is being authorised. You may be asked to enter your 3D Secure Password” appears (see screenshot below).
  • I do receive the 3D Secure password via SMS
  • After a while, the box disappear and the app is stuck on a dark blue screen without anything else on the screen
  • If I leave / reopen the app, I have to renter my password and I end up on a the scree with the personal details of the card I’m trying to add, with a transparent dark bleu overlay and I cannot click on anything.

I am not the only one experiencing this issue, I’ve tried with different accounts, on different phones, with different cards. It has been going on for more than a month. It used to work (on my phone, with the same card).

Let me know if I can provide you with more information,
Philippe


#3

I had exactly the same issue but today I installed the beta version of android and it works fine, i can add my card and top up.
No more issue, the 3ds secure message pops up and verify my action like it used to.
I hope that it solves your issue aswell.


#4

which revolut app version was you trying? i have same issue


#5

I have also experienced the same problem - blank page on 3-D Secure Prompt window on an Android phone. Since the prompt is being shown in a WebView window I have explicitly installed the latest version of WebView from the Play Store and the problem was solved.