1st time use: Can't verify card to top up, chat closed although it's pre 10pm in UK


#1

I’m currently experiencing the worst customer journey for a new product that I’ve ever had.

I downloaded the app, filled in everything as attempted to top up. I get to the point where the app tells me it’s working on it and I might need to put in 3DS information. I then get a blank screen and nothing else. I can’t do anything in the app, can’t go back so I have to force close and try again.

I try again, same thing.

I contact chat. I’m asked to change my internet connection. I go from Wi-Fi to 3g. Try again. No change. Force close.

I contact chat again. I’m asked to log out and in again. I do that, nothing changes, force close and come back.

I contact chat a third time. I’m asked to uninstall and reinstall an app that i first downloaded not twenty minutes beforehand. I do it. Nothing changes. Force close.

Fourth chat. I’m asked to ring my bank and see if everything is ok. I ask if my bank is going to think I’m crazy for asking whether my 3DS is set up correctly. Surely it’s a case of being set up or not? I ask if there’s any question I should ask them, any technical question that might help. I’m told to ask for a code. I have no idea where I’ll put this code as I’m getting a blank white screen but grand. I tell the agent that i believe the issue is with revolut’s app but am told that no, talk to the bank first. I should mention, I’m sitting on the app waiting for updates, I get none. I’m literally waiting over 20 minutes in the middle of the day for acknowledgement. It isn’t until I force close the app and go back in that i see that there’s a message from the staff.

I get home, call my bank who were extremely helpful. Get a four digit code. Play around with the app to discover where it goes. I put it in, I take a picture of my card and nope. Card or code is wrong. I try another transfer, same issue. Ring bank to see if they have a new code, they don’t. Tell me to try again and if not, to ring in an hour in case it comes through.

I tried twice more, once after ringing the bank and talking to their customer service after the original allotted hour they mentioned. Still no go.

I started a chat at 1957. Nothing. Literally nothing in two hours despite repeated force closes. I try to call. I can only cancel my card that way. See if there’s another method of contact, there is, it’s Facebook. I have to download the messenger app in order to contact your staff. I send a message at 21.14 UK time and am told:
Hi , thanks for your message. We’re not here right now, but we’ll get back to you soon.
Our in-App support chat is available: Mon-Fri: 8am - 10pm UKT, Sat-Sun: 12pm - 6pm UKT & 24/7 exclusive support for all the Premium accounts.

So apparently 21.14 in the UK is after 22.00 UK time on a Thursday. This is a bit of a revelation to me, shockingly.

I’m now at the point where I find your app is extremely buggy and I’m not entirely sure I want to continue using it but here is the rub. Thinking that it might be an identity issue I went ahead and verified myself. You now have a copy of my driver’s license in your database. I want this removed if I can’t use your app.

Considering I can’t get through to a human (even though I’m writing this pre 22.00), can someone please inform me how to either solve my issues or remove my documents / card / account details from your database?

Thanks.